January 2, 2013

Why is Amazon a Mac hater?

Amazon offers a publishing service that delivers blog content to Kindles and kindred e-readers. The subscription costs $.99/month, one-third of which goes to Amazon.
I set up an account and will make this stream o’ bits available through the Kindle channel. (If anyone subscribes, I will donate my proceeds to charity. I’m interested in the publishing process, not in making money.)
One annoying hitch, however, is that, when I go to the publisher’s page to log in to my account, I’m greeted with this warning.

Prompt to install IE or Firefox

Internet Explorer isn’t available and you really have to dig to find Firefox versions older than the current  (17.0) release.
It turns out that the message is benign. Safari and Chrome, the two browsers that I have installed on my Mac, work ok.